The Secret To Getting Photoshop Elements To Work With Lightroom

I hear more and more that photographers who use Lightroom are now using Elements as well (as opposed to Element’s big brother, the full version of Photoshop). With Elements at an insanely cheap price ($59 at Amazon for example), I honestly can’t blame ‘em. Elements is a hugely powerful program and I think for a lot of photographers out there, that just want basic cloning/healing/layers/selections/retouching, it’ll take care of most of your needs.

There is a trick, however, if you’re setting up Elements as an external editor with Lightroom (on the Mac that is). First, you go to menu to Lightroom > Preferences and click on the External Editing tab. Now, your first inclination (at least it was mine) is that you go to the Photoshop Elements folder and select the first Elements application icon that you see for your editor. But if you do, when you try to edit a photo in Elements you’ll see the Elements interface open, but the photo will never show up. Here’s the fix. Instead of choosing the Elements icon in the main application folder, you need to go to Applications > Adobe Photoshop 11 > Support Files and choose the Adobe Photoshop Elements Editor.app file. Here’s a screenshot of what it looks like.

elementsapp

Now when you go to edit your photo from Lightroom in to Elements, it’ll automatically create a copy and launch Elements for you, and the photo will automatically open. When you’re done just choose File > Save and return to Lightroom to see the edited version.

SIDE NOTE: If you’re into Elements and learning more about it, I write articles for a really great mini-magazine/website called Photo Elements Techniques. Here’s the link to check them out.

From what I’ve heard, this has always been a big stumbling block for many Elements users so I hope this helps out. Take care!

Author: Matt K

Matt is a full time Education Director for the NAPP and Kelby Training. He's a best-selling author of various books on Photoshop and Photography co-hosts the live weekly photography talk show "The Grid" and is co-host of "Photoshop User TV". In his spare time he practices as a 1st degree black belt in Taekwondo and enjoys spending time with his family in Tampa, FL.

Share This Post On
468 ad

14 Comments

  1. this is all well and good for MAC users, but what about windows user?

    Post a Reply
    • Just choose the Elements application in the Elements folder like you normally would. PC doesn’t have two files that can confuse you like the Mac does.

      Post a Reply
  2. Hey Matt
    Good suggestion on Elements. I have used Elements for years and found it has most of the Photoshop features I need. My toolbox currently includes Lightroom, Elements, and Nik Collection with Lightroom being where I do all my file management and most editing. I recommend Elements over full Photoshop to all my photographer buddies.

    Post a Reply
  3. I’m running PSE 11 on my iMac and use lr4.4 & NIK’s Suite. I also use E+ for those extra power for things like alpha channels, color channels, smart obj, smart filters and more – It costs $12.50.
    It works for me. I hope Adobe doesn’t take PSE to subscription land!! I do a lot of restorations work and need my layers. [@|@]

    Post a Reply
  4. What about tags and categories working with both Lghtroom and Elements?

    Post a Reply
  5. Matt, or anyone, although I can transfer images from LR 3 to PSE 9 for external editing, when ready to replace the image in LR 3, and I click “Save,” the image does not go to the LR 3 catalogue from where it came. Instead, I am required to select a file on my hard drive. Then I have to import it back into the LR 3 catalogue, a pain. Any suggestions? Thanks. – Don

    Post a Reply
  6. For some reason the integration between my element and lightroom 4 do not work anymore. Elements takes my photo from lightroom but when it goes back into lightroom the file is there but there are no photoshop edits. Also some time the pop of using lightroom edits does not show up when going into photoshop?

    Post a Reply
  7. Im having the same problem as Don and Tammy. Please help

    Post a Reply
  8. I’m having the same issue as Don, Kathy and Tammy. Does anyone have an answer? Thanks!

    Post a Reply
  9. what if I can’t find my support file folder? when I go to applications all the other folders are there but support files

    Post a Reply
  10. It is able to automatically save a copy to lightroom but it’s being sent as the original image not the edited copy? now I have 3 images of the same thing but all the editing I did on element did not copy. Help pls. I have 3 images because I tried twice and still no difference.

    Post a Reply

Submit a Comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>