Lightroom 1.3.1 Update

It seems like it was just a couple weeks ago that I was writing about the Lightroom 1.3 update and now there’s another one. Really though, there’s nothing major here. Just a few bug fixes and tweaks that some folks have experienced since updating to 1.3. Personally, I haven’t experienced any issues but I’m not running Leopard yet either. Anyway, below are the Mac/PC links if you need to download:
- Lightroom 1.3.1 for Mac
- Lightroom 1.3.1 for Windows

Author: Matt K

Matt is a full time Education Director for the NAPP and Kelby Training. He's a best-selling author of various books on Photoshop and Photography co-hosts the live weekly photography talk show "The Grid" and is co-host of "Photoshop User TV". In his spare time he practices as a 1st degree black belt in Taekwondo and enjoys spending time with his family in Tampa, FL.

Share This Post On
468 ad

7 Comments

  1. v1.3 affected me a lot. All of my compressed D1x NEFs were “magentized” and this happened also to some D100 users. I’m glad Adobe solved this issue quickly.

    Post a Reply
  2. I loaded LR 1.3.1 and went back to 1.3. The new version was telling me that my files had been altered by both LR and an external program. When I tried to resolve using the dialog provided by LR, all the files had their Develop history re-set. Luckily, I was doing the resolve on a folder basis and not the entire catalog. I have used ACDSee on some of my files to put the original file name in the caption area but that is the only external mod I have done. I have lost weeks of development work! The reset happened using either option – save disk settings or overwrite (can’t remember the exact wording)

    PC XP SP2

    Post a Reply
  3. I’m having some strange things now with 1.3.1 too . . . my develop sliders now show “M” where there was before a numerical value, and some text is invisible now . . . weird.

    Post a Reply
  4. I take it back. LR 1.3.1 was apparently not the cause of my troubles. Not sure what the cause of all my images appearing to have been changed in 2 different programs but it also showed up in LR 1.3. The greater problem I think is that so many of us have so little trust in Adobe getting this software right, that we automatically assume it is LR that is the cause of a problem. I have always been impressed with the power of Adobe software, but their implementation of Windows conventions leaves much to be desired.

    Post a Reply
  5. Hey, I have a problem: when I try to “Edit in Adobe Photoshop CS3″, and select “Edit a Copy”… It doesn’t open in Photoshop CS3 a .PSD file: it opens a .JPG file.

    Is that ok? Comments?

    PC – Vista

    Post a Reply
  6. On a Mac 1.3.1 has no problem. Since I’m starting with my photography, I did some freebie that got more than 3k pictures in 2 months. I’ve changed about 3 times my work flow. Got from a collections main thing to a folder main thing, so I did a lot of copying inside LR. The only thing that I didn’t pass through the ringer is the hookup with PS. Since I’m not that good in PS. But this will come.

    And in all that time NOT PROBLEMs what so ever.

    Post a Reply

Submit a Comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>